composer安装包报错

我在安装这个包

composer global require "fxp/composer-asset-plugin:~1.1"

提示了以下信息

 The openssl extension is required for SSL/TLS protection but is not available. If you can not enable the openssl extension, you can disable this error, at your own risk, by setting the disabl e-tls option to true.

是不是说如果把tls禁用掉就可以继续用了,然后后果自负?


补充,我把php里面的php.ini的openssl扩展打开了

经大神指导已经解决,主要是php.ini没有设置扩展路径的的原因。
而且我之前下过wamp,系统环境变量里面有残留的路径,要删掉

php.ini里设置
extension_dir = "ext"

php的openssl扩展没开,编辑php.ini打开openssl扩展之后即可

给你补充一点,快速检查你扩展是否开启:

php -m

如果列出的扩展中没有你所开启的扩展,请依次检查:

  • php 版本,这个对于环境中存在多种 php 版本时是首要检查项,因为 web 服务和 CLI 很可能版本不一致;

  • 配置文件路径

  • 扩展路径,比如题主遇到的问题;

  • 扩展版本,这个会有报错,一般执行 php -m 命令就会提示

发表评论

电子邮件地址不会被公开。 必填项已用*标注