使用Fragment时出现了奇怪的错误

API版本是23

试试getSupportFragmentManager

新建fragment继承的extends Fragment时有两种情况,一是导入app的,这时用getFragmentManager。
但是默认的是继承v4的,这个用getSupportFragmentManager。
所以你把fragment改为导入app,或者改为getSupportFragmentManager

同意楼上的说法,Fragment用的是哪个包的,楼主确认一下

发表评论

电子邮件地址不会被公开。 必填项已用*标注